On Aug 12, 2026, we identified an issue affecting Translation Memory update processing following a service deployment. This caused some translation tasks to fail or remain in progress during the TM Update step. The issue was traced to a configuration change introduced as part of the deployment. The configuration has been restored and the service redeployed.
We apologize for any inconvenience this issues has caused
Posted Aug 14, 2026 - 19:39 UTC
Resolved
The incident is now resolved. A postmortem will be shared within the next 24 hours.
We thank you for your patience and understanding.
Posted Aug 12, 2026 - 15:46 UTC
Investigating
Dear Customer,
We are currently experiencing an issue affecting task processing. Our technical team is actively investigating the issue and working to restore normal processing as soon as possible.
We will provide timely updates as we make progress and keep you informed of any significant developments.
We apologize for the disruption and appreciate your patience and understanding.
Posted Aug 12, 2026 - 13:57 UTC
This incident affected: Trados Cloud (EMEA) (Projects (EMEA)).