Project Email Notifications Not Being Delivered

Incident Report for Trados Cloud

Postmortem

Dear Customer,

We recently identified and resolved an issue that caused delays in the delivery of email notifications within Trados Enterprise.

During the incident, customers may have experienced delays in receiving project-related email notifications, including notifications associated with project creation and workflow activities.

The issue was caused by an unusually high volume of notification events, which resulted in processing delays within the notification delivery system. No notifications were lost; however, some notifications were delivered later than expected. Our Engineering teams cleared the backlog and restored normal notification processing.

We are implementing additional safeguards and enhancing monitoring to help prevent similar incidents from occurring in the future.

We apologize for the inconvenience and appreciate your patience and understanding while we worked to resolve the issue.

Regards,
RWS Group

Posted Sep 02, 2026 - 13:37 UTC

Resolved

Dear Customer,

The issue causing delays in project-related email notifications has been resolved.

During the incident, users experienced delays in receiving project-related email notifications. Our teams investigated the issue and took the necessary actions to restore normal notification processing. Email notifications are now being delivered as expected, and the notification queue has returned to normal operating levels.

Any delayed notifications have been processed, and the service is functioning normally.

We apologize for the inconvenience this may have caused and appreciate your patience while we worked to resolve the issue.

If you continue to experience notification delivery problems, please contact support team via usual channels.
Posted Sep 01, 2026 - 11:47 UTC

Investigating

Dear Customer,

We are investigating an issue that may be causing delays in the delivery of project-related email notifications for Trados users.

As a result, you may experience delays in receiving notifications related to project activities. Our teams are actively investigating the issue and working to restore normal notification processing as quickly as possible.

We will provide further updates as soon as additional information becomes available.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 01, 2026 - 09:49 UTC
This incident affected: Trados Cloud (EMEA) (Projects (EMEA)).