We are currently investigating an issue with Trados Enterprise.

Incident Report for Trados Cloud

Resolved

The issue has been resolved. Our teams will investigate the cause and a review will be held later this week.

Thank you for your understanding,
Posted Apr 13, 2026 - 15:27 UTC

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 14:55 UTC

Investigating

We are currently investigating this issue.
Posted Apr 13, 2026 - 14:55 UTC
This incident affected: Trados Cloud (EMEA) (Login Services (EMEA)).