"Translation Memory Service is currently unavailable", error messages

Incident Report for Trados Cloud

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 14:55 UTC

Update

The issue is now resolved. The team is investigating the cause of the instability. We will provide more information once they are done their investigation.

Thank you for your understanding,
Posted Aug 22, 2025 - 14:54 UTC

Investigating

Please be advised that our support teams are currently investigating an issue with the Translation services. We will provide hourly updates or confirm once the status of the issue changes.
Posted Aug 22, 2025 - 14:41 UTC
This incident affected: Trados Cloud (EMEA) (Linguistic Resources (EMEA)).