Creation of projects is failing

Incident Report for Trados Cloud

Resolved

The issue is now resolved. The team is investigating the cause of the instability and will provide more information once they are done their investigation.

Thank you,
Posted Sep 12, 2025 - 16:05 UTC

Investigating

Please be advised that our support teams are currently investigating an issue affecting project creations. We will provide hourly updates or confirm once the status of the issue changes.

Thank you for your understanding,
Posted Sep 12, 2025 - 15:51 UTC
This incident affected: Trados Cloud (EMEA) (Projects (EMEA)).