Issues login into Trados Cloud

Incident Report for Trados Cloud

Postmortem

Earlier today, some users experienced login issues when accessing Trados and Language Weaver in the Production Europe environment. The issue was caused by a temporary external authentication connectivity/DNS problem and has fully resolved.

✅ All services are now operating normally
✅ Users can log in successfully
✅ No customer data was impacted

We continue to monitor the platform to ensure stability. Thank you for your patience.

Posted Apr 22, 2026 - 19:41 UTC

Resolved

The issue is now resolve.

We're sorry for the inconvenience and are grateful for your understanding

Thank you,
Posted Apr 22, 2026 - 19:18 UTC

Investigating

Please be advised,

We are aware of some login issues, the RWS technical teams are currently investigating.
Posted Apr 22, 2026 - 18:50 UTC
This incident affected: Trados Cloud (EMEA) (Login Services (EMEA)).