Delays in Project Processing and Workflow Execution

Incident Report for Trados Cloud

Postmortem

On August 31, 2026, Trados Cloud experienced processing delays affecting the Analysis and Preprocessing stages of translation workflows. While tasks completed successfully, a database and system queue bottleneck resulted in delayed handoffs between workflow steps. No data was lost or corrupted.

We sincerely apologize for any inconvenience caused to your operations.

Posted Sep 02, 2026 - 14:20 UTC

Resolved

Dear customer,

Our engineering teams have continued to monitor platform performance following the processing backlog reported earlier. Based on the latest observations, workflow processing has remained stable for approximately the last 20 hours, and platform health indicators continue to operate within expected ranges.

The queue backlog that was contributing to delays between workflow stages has been significantly reduced, and affected workflows are progressing normally. We are not currently observing the elevated processing delays that triggered the earlier notification.

As a precaution, we will continue to closely monitor platform performance and processing queues to ensure sustained stability. Should any further issues be identified, we will communicate updates promptly.

We sincerely apologize for any inconvenience caused by the earlier delays and appreciate your patience and understanding while our teams worked to restore normal operations.
Posted Sep 01, 2026 - 10:08 UTC

Monitoring

Dear clients,

As stated earlier, some files are experiencing significant delays during the Analysis and Pre-processing workflow stages. While tasks are successfully advancing to "Completed" and moving to subsequent stages (for example, taking approximately 10 minutes for individual analysis tasks), the hand-off and generation of successive tasks are experiencing a queue backlog.

Our latest platform metrics indicate that the system queue load is actively reducing and platform health indicators have returned to their optimal operational bands.

If you have urgent projects that appear stuck in the analysis stage, please try re-creating the project to trigger active task progression. We will continue to actively monitor the queue and system metrics through the night to ensure complete recovery.

We apologize for the inconvenience this delay has caused and appreciate your patience as we restore operations to full capacity.
Posted Aug 31, 2026 - 16:00 UTC

Identified

Dear Customer,

Our technical teams continue to actively investigate and address the underlying cause of the increased processing times. At this time, some projects may experience delays as they progress through various processing stages, resulting in longer-than-expected completion times.

As investigation and mitigation activities continue, you may continue to experience intermittent processing delays. We are closely monitoring the service and working to improve processing performance as quickly as possible.

We understand the impact this may have on your operations and appreciate your patience while we work to resolve the issue.

We will provide further updates as additional information becomes available.
Posted Aug 31, 2026 - 13:10 UTC

Investigating

Hello,

We are currently investigating a service degradation that is causing delays in workflow processing across the platform.

Our technical team is actively monitoring the environment and working to mitigate the impact. We will continue to provide updates as more information becomes available.

Apologies for any inconvenience this may cause.
Posted Aug 31, 2026 - 11:42 UTC
This incident affected: Trados Cloud (EMEA) (Projects (EMEA)).