Recuring Authentication issues

Incident Report for Trados Cloud

Postmortem

On August 6, 2026, from 08:40 UTC to 16:23 UTC, Trados Cloud experienced intermittent login and token authorization failures during TM lookup operations. This was caused by database performance degradation on our caching layer, which delayed authentication requests and led to temporary rate-limiting by our identity provider (Auth0).

We immediately mitigated the issue by flushing the affected database caches, restoring full service stability. To prevent recurrence, we also deployed a hotfix on August 7, 2026, to isolate the blacklist cache database.

Posted Aug 07, 2026 - 12:32 UTC

Resolved

As previously advised, we deployed an update to fix the authentication issue at approximately 07:00 UTC this morning. We have seen no further occurrences of this issue since the fix was deployed, so we will now mark this incident as resolved. If you continue to encounter issues please raise a support case via https://gateway.rws.com/
Posted Aug 07, 2026 - 11:08 UTC

Update

Please be advised, there have been no reoccurrences since our last update. The permanent fix is scheduled for deployment early tomorrow morning. We will advise once completed and proceed to change the incident status to resolved. A Post-Mortem will also be shared within the next 24 hours following an internal incident review.

Again we truly appreciate your patience and understanding and know that RWS is fully committed to offering its clients a reliable and stable service.

Thank you,
Posted Aug 06, 2026 - 19:05 UTC

Monitoring

Short recurring authentication issues happened during the day. The RWS team engineers have been investigating the situation.

We are sorry for the inconvenience and appreciate your time and patience while the RWS teams work on a permanent resolution.
Posted Aug 06, 2026 - 16:29 UTC
This incident affected: Trados Cloud (EMEA) (Login Services (EMEA)).