Online Editor and Project resource availability

Incident Report for Trados Cloud

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 15:19 UTC

Investigating

We are currently investigating an issue with Online Editor and the availability of project resources. Users might see errors when accessing Online Editor or Project related resources.
Posted Mar 20, 2025 - 15:07 UTC
This incident affected: Trados Cloud (EMEA) (Projects (EMEA), Online Editor (EMEA)).