Delay in Project processing

Incident Report for Trados Cloud

Resolved

The issue impacting project processing has been resolved. Services are now back to normal, and processing is proceeding as expected.

We appreciate your patience and understanding while we worked on the issue.
Posted Apr 14, 2026 - 10:57 UTC

Investigating

We are currently experiencing delays in project processing. Our technical teams are actively investigating the issue and working to resolve it as soon as possible.

We will keep you updated on the progress
Posted Apr 14, 2026 - 08:42 UTC
This incident affected: Trados Cloud (EMEA) (Projects (EMEA)).